Degraded Performance of our UI
Incident Report for Valimail
Resolved
This incident has been resolved
Posted Feb 09, 2023 - 19:04 PST
Monitoring
We are currently monitoring an issue with degraded performance in the UI. Some pages may load slowly or time out. Critical components are unaffected
Posted Feb 09, 2023 - 18:01 PST
This incident affected: Valimail Enforce® (Application) and Valimail Monitor® (Application).