Monitoring Microsoft 365 Issues
Incident Report for Valimail
Resolved
After further investigation, we've determined that Microsoft's mailbox issue has no impact on our services. This issue is resolved.
Posted Jun 21, 2022 - 09:37 PDT
Monitoring
We have confirmed that this issue affects our Mailbox Connector and Defend Application. Mailbox access is required to ingest messages into our systems. We are continuing to monitor for a resolution from Microsoft.
Posted Jun 21, 2022 - 08:32 PDT
Investigating
We are closely monitoring an issue with customers in EMEA, North America, and Asia-Pacific being unable to access their Microsoft 365 mailboxes. This issue may impact our Mailbox Connector and Defend Application.
For more information, visit Microsoft's status page: https://portal.office.com/servicestatus
Posted Jun 21, 2022 - 08:26 PDT
This incident affected: Valimail Defend® (Application) and Valimail Enforce® (Mailbox Connector).