Email Insights Report Not Accessible

Incident Report for Valimail

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jan 25, 2024 - 09:30 PST

Investigating

We are currently investigating an issue with the Email Insights report not being accessible in the app.
Posted Jan 25, 2024 - 06:22 PST
This incident affected: Valimail Enforce® (Application).